Skip to main content

Drupal 8 System requirements

Up-to-date system requirements can be found at Drupal.org

PHP
      PHP 5.5.9 or higher
      More details about PHP requirements, including PHP memory ~ click here

Database
     More details about Database server requirements~ click here
     MySQL 5.5.3/MariaDB 5.5.20/Percona Server 5.5.8 or higher with PDO and an InnoDB-compatible primary storage engine,
     PostgreSQL 9.1.2 or higher with PDO,
     SQLite 3.7.11 or higher

Web server
     More details about Web server requirements ~ click here
     Apache
     Nginx
     Hiawatha
     PHP Built-in Web Server (Development Only)

Browser requirements
     More details about Browser requirements ~ click here
     Internet Explorer 9.x and later,
     Firefox 5.x and later
     Opera 12 and later
     Safari 5.x and later
     Google Chrome

Back to top