Skip to main content

Installing Drupal 8 Theme with Composer

anisur$ composer require drupal/bootstrap

Using version ^3.17 for drupal/bootstrap
./composer.json has been updated
> DrupalProject\composer\ScriptHandler::checkComposerVersion
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 0 updates, 0 removals
  - Installing drupal/bootstrap (3.17.0): Downloading (100%)         
Writing lock file
Generating autoload files
> DrupalProject\composer\ScriptHandler::createRequiredFiles
anisur$ drupal thi bootstrap
 The "Bootstrap" theme has been installed successfully

 // cache:rebuild

 Rebuilding cache(s), wait a moment please.

                                                                                                    
 [OK] Done clearing cache(s).                                                                       
                                                                                                    

anisur$ drupal thi bootstrap --set-default
 Nothing to do. Theme "Bootstrap" is already installed

 // cache:rebuild

 Rebuilding cache(s), wait a moment please.

                                                                                                    
 [OK] Done clearing cache(s).                                                                       
                                                                                                    

anisur$ composer update
> DrupalProject\composer\ScriptHandler::checkComposerVersion
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 0 installs, 1 update, 0 removals
  - Updating stecman/symfony-console-completion (0.8.0 => 0.9.0): Downloading (100%)         
Writing lock file
Generating autoload files
> DrupalProject\composer\ScriptHandler::createRequiredFiles
Back to top